PT-2024-21844
CVE-2024-27355
·
Published
2023-08-25
·
Updated
2026-09-15
Description by
CVSS 2.0
7.8
HighMetricsAV:N/AC:L/Au:N/C:N/I:N/A:C
Name of the Vulnerable Software and Affected Versions
phpseclib versions 1.x through 1.0.22
phpseclib versions 2.x through 2.0.46
phpseclib versions 3.x through 3.0.35
Description
An issue was discovered in phpseclib when processing the ASN.1 object identifier of a certificate. A sub identifier may be provided that leads to a denial of service due to CPU consumption for decodeOID.
Recommendations
For phpseclib versions 1.x through 1.0.22, update to version 1.0.23 or later.
For phpseclib versions 2.x through 2.0.46, update to version 2.0.47 or later.
For phpseclib versions 3.x through 3.0.35, update to version 3.0.36 or later.
Found an issue in the description? Have something to add? Feel free to write us 👾