PT-2024-21907

CVE-2024-27454

·

Published

2024-02-25

·

Updated

2026-10-12

Description by

CVSS 3.1
7.5
High
MetricsAV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
Name of the Vulnerable Software and Affected Versions orjson versions prior to 3.9.15
Description The issue is related to the orjson.loads function in orjson, which does not limit recursion for deeply nested JSON documents. This can lead to potential exploitation.
Recommendations For versions prior to 3.9.15, update to version 3.9.15 or later to resolve the issue. As a temporary workaround, consider restricting the use of deeply nested JSON documents until a patch is applied.
Exploitability
Exploit
Fix
Impacts
Researchers
Vendors
Affected products
Related identifiers
GHSA-PWR2-4V36-6QPR
ECHO-858E-FAEA-85EF
OPENSUSE-SU-2024:13735-1
OPENSUSE-SU-2024:13780-1
OPENSUSE-SU-2026:12024-1
OPENSUSE-SU-2026:12033-1
PYSEC-2024-40
Found an issue in the description? Have something to add? Feel free to write us 👾