PT-2024-22136
CVE-2024-2792
·
Published
2024-04-09
·
Updated
2025-12-02
Description by
CVSS 3.1
6.4
MediumMetricsAV:N/AC:L/PR:L/UI:N/S:C/C:L/I:L/A:N
Name of the Vulnerable Software and Affected Versions
Elementor Addon Elements plugin for WordPress versions up to, and including, 1.13.2
Description
The issue is related to Stored Cross-Site Scripting via widgets due to insufficient input sanitization and output escaping on user-supplied attributes. This allows authenticated attackers with contributor-level access and above to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page.
Recommendations
For versions up to, and including, 1.13.2, update to a version later than 1.13.2 to resolve the issue. As a temporary workaround, consider restricting contributor-level access and above to minimize the risk of exploitation. Additionally, restrict access to widgets to prevent arbitrary web script injection until a patch is available.
Found an issue in the description? Have something to add? Feel free to write us 👾