PT-2024-22145

CVE-2024-27931

·

Published

2024-03-05

·

Updated

2026-04-14

Description by

CVSS 3.1
6.5
Medium
MetricsAV:N/AC:L/PR:L/UI:N/S:U/C:N/I:H/A:N
Name of the Vulnerable Software and Affected Versions Deno versions prior to 1.41.1
Description Insufficient validation of parameters in Deno.makeTemp* APIs would allow for creation of files outside of the allowed directories. This may allow the user to overwrite important files on the system that may affect other systems. A user may provide a prefix or suffix to a Deno.makeTemp* API containing path traversal characters.
Recommendations For Deno versions prior to 1.41.1, update to Deno 1.41.1 to resolve the issue. As a temporary workaround, consider restricting the use of the Deno.makeTemp* APIs to prevent potential exploitation. Avoid using prefixes or suffixes containing path traversal characters in the Deno.makeTemp* APIs until the issue is resolved.
Exploitability
Exploit
Fix
Impacts
Researchers
Vendors
Affected products
Related identifiers
GHSA-HRQR-JV8W-V9JH
JLSEC-2026-103
Found an issue in the description? Have something to add? Feel free to write us 👾