PT-2024-22690
CVE-2024-29038
·
Published
2024-04-30
·
Updated
2026-07-02
Description by
CVSS 3.1
4.3
MediumMetricsAV:L/AC:L/PR:N/UI:N/S:C/C:L/I:N/A:N
Name of the Vulnerable Software and Affected Versions
tpm2-tools versions prior to 5.7
Description
The issue allows a malicious attacker to generate arbitrary quote data that is not detected by
tpm2 checkquote. This is related to the Trusted Platform Module (TPM2.0) tools.Recommendations
For versions prior to 5.7, update to version 5.7 to resolve the issue. As a temporary workaround, consider restricting the use of the
tpm2 checkquote function until the update is applied. Found an issue in the description? Have something to add? Feel free to write us 👾