PT-2024-22738
CVE-2024-29117
·
Published
2024-03-19
·
Updated
2025-03-18
Description by
CVSS 3.1
7.1
HighMetricsAV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:L
Name of the Vulnerable Software and Affected Versions
Contact Forms by Cimatti versions 1.7.0 and earlier
Description
The issue is related to improper neutralization of input during web page generation, which allows stored cross-site scripting. This means an attacker can inject malicious scripts into the website, potentially leading to unauthorized access or control.
Recommendations
For versions 1.7.0 and earlier, update to a version later than 1.7.0 to resolve the issue. As a temporary workaround, consider disabling the plugin until a patch is available. Restrict access to the plugin's functionality to minimize the risk of exploitation. Avoid using the plugin's features that allow user input until the issue is resolved.
Found an issue in the description? Have something to add? Feel free to write us 👾