PT-2024-22833
CVE-2024-29237
·
Published
2024-03-27
·
Updated
2025-01-14
Description by
CVSS 3.1
8.8
HighMetricsAV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H
Name of the Vulnerable Software and Affected Versions
Synology Surveillance Station versions prior to 9.2.0-11289
Synology Surveillance Station versions prior to 9.2.0-9289
Description
The issue is related to an SQL Injection vulnerability due to improper neutralization of special elements used in an SQL command. This vulnerability affects the ActionRule.Delete webapi component and allows remote authenticated users to inject SQL commands via unspecified vectors.
Recommendations
For versions prior to 9.2.0-11289, update to version 9.2.0-11289 or later.
For versions prior to 9.2.0-9289, update to version 9.2.0-9289 or later.
As a temporary workaround, consider restricting access to the ActionRule.Delete webapi component until a patch is available.
Found an issue in the description? Have something to add? Feel free to write us 👾