PT-2024-2397

CVE-2024-28107

·

Published

2024-03-25

·

Updated

2025-01-09

Description by

CVSS 2.0
9.0
High
MetricsAV:N/AC:L/Au:S/C:C/I:C/A:C
Name of the Vulnerable Software and Affected Versions phpMyFAQ versions prior to 3.2.6
Description A SQL injection vulnerability has been discovered in the insertentry and saveentry functions when modifying records due to improper escaping of the email address. This allows any authenticated user with the rights to add/edit FAQ news to exploit this vulnerability to exfiltrate data, take over accounts and in some cases, even achieve remote code execution. The vulnerability can be exploited by modifying the email and notes parameters in the body of the POST request to the /admin/?action=insertentry and /admin/?action=saveentry API endpoints.
Recommendations To resolve the issue, update phpMyFAQ to version 3.2.6 or later. As a temporary workaround, consider restricting access to the insertentry and saveentry functions until a patch is available. Additionally, restrict the use of the email and notes parameters in the affected API endpoints to minimize the risk of exploitation.
Exploitability
Exploit
Fix
Impacts
Researchers
Vendors
Affected products
Related identifiers
GHSA-2GRW-MC9R-822R
Found an issue in the description? Have something to add? Feel free to write us 👾