PT-2024-25107
CVE-2024-3307
·
Published
2024-05-02
·
Updated
2025-03-08
Description by
CVSS 3.1
6.4
MediumMetricsAV:N/AC:L/PR:L/UI:N/S:C/C:L/I:L/A:N
Name of the Vulnerable Software and Affected Versions
HT Mega – Absolute Addons For Elementor plugin for WordPress versions up to, and including, 2.4.9
Description
The issue is related to Stored Cross-Site Scripting via the Countdown widget's attributes due to insufficient input sanitization and output escaping. This allows authenticated attackers with contributor access or above to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page.
Recommendations
For versions up to, and including, 2.4.9, update to a version higher than 2.4.9 to resolve the issue. As a temporary workaround, consider restricting access to the Countdown widget's attributes to minimize the risk of exploitation.
Found an issue in the description? Have something to add? Feel free to write us 👾