PT-2024-25560

CVE-2024-33927

·

Published

2024-05-03

·

Updated

2024-05-03

Description by

CVSS 3.1
6.5
Medium
MetricsAV:N/AC:L/PR:L/UI:R/S:C/C:L/I:L/A:L
Name of the Vulnerable Software and Affected Versions Giphypress versions 1.6.2 and earlier
Description The issue is related to improper neutralization of input during web page generation, which allows for stored cross-site scripting (XSS). This means that an attacker can inject malicious scripts into the website, potentially affecting users who access the compromised page. The estimated number of potentially affected devices worldwide is not specified. There is no information provided about real-world incidents where this issue was exploited.
Recommendations For versions 1.6.2 and earlier, update to a version later than 1.6.2 to resolve the issue. As a temporary workaround, consider restricting user input to prevent malicious script injection until a patch is available. Avoid using potentially vulnerable API endpoints, such as /api/v1/upload or /users/{id}, in the affected Giphypress versions until the issue is resolved.
Exploitability
Fix
Impacts
Researchers
Vendors
Affected products
Related identifiers
Found an issue in the description? Have something to add? Feel free to write us 👾