PT-2024-2610
CVE-2022-34321
·
Published
2024-03-12
·
Updated
2026-10-16
Description by
CVSS 3.1
9.9
CriticalMetricsAV:N/AC:L/PR:L/UI:N/S:C/C:H/I:H/A:H
Name of the Vulnerable Software and Affected Versions
Apache Pulsar versions 2.6.0 through 2.10.5
Apache Pulsar versions 2.11.0 through 2.11.2
Apache Pulsar versions 3.0.0 through 3.0.1
Apache Pulsar version 3.1.0
Description
The issue is related to an improper authentication vulnerability in the Apache Pulsar Proxy, allowing an attacker to connect to the "/proxy-stats" endpoint without authentication. This exposes detailed statistics about live connections and allows modification of the logging level of proxied connections without proper authentication credentials. The known risks include exposing sensitive information, such as connected client IP, and unauthorized logging level manipulation, which could lead to a denial-of-service condition by significantly increasing the proxy's logging overhead.
Recommendations
Apache Pulsar version 2.10 users should upgrade to at least version 2.10.6.
Apache Pulsar version 2.11 users should upgrade to at least version 2.11.3.
Apache Pulsar version 3.0 users should upgrade to at least version 3.0.2.
Apache Pulsar version 3.1 users should upgrade to at least version 3.1.1.
Users operating versions prior to those listed above should upgrade to the aforementioned patched versions or newer versions.
Exploitability
Exploit
Fix
Impacts
Researchers
Vendors
Affected products
Found an issue in the description? Have something to add? Feel free to write us 👾