PT-2024-2614

CVE-2024-28098

·

Published

2024-03-12

·

Updated

2026-10-16

Description by

CVSS 3.1
9.9
Critical
MetricsAV:N/AC:L/PR:L/UI:N/S:C/C:H/I:H/A:H
Name of the Vulnerable Software and Affected Versions Apache Pulsar versions 2.7.1 through 2.10.5 Apache Pulsar versions 2.11.0 through 2.11.3 Apache Pulsar versions 3.0.0 through 3.0.2 Apache Pulsar versions 3.1.0 through 3.1.2 Apache Pulsar version 3.2.0
Description The issue is related to improper authorization in Apache Pulsar, allowing authenticated users with only produce or consume permissions to modify topic-level policies, such as retention, TTL, and offloading settings. These management operations should be restricted to users with the tenant admin role or super user role.
Recommendations Apache Pulsar version 2.10 users should upgrade to at least version 2.10.6. Apache Pulsar version 2.11 users should upgrade to at least version 2.11.4. Apache Pulsar version 3.0 users should upgrade to at least version 3.0.3. Apache Pulsar version 3.1 users should upgrade to at least version 3.1.3. Apache Pulsar version 3.2 users should upgrade to at least version 3.2.1. Users operating versions prior to those listed above should upgrade to the aforementioned patched versions or newer versions.
Exploitability
Exploit
Fix
Impacts
Researchers
Vendors
Affected products
Related identifiers
GHSA-G627-R579-RW35
OESA-2026-4329
OESA-2026-4330
OESA-2026-4331
Found an issue in the description? Have something to add? Feel free to write us 👾