PT-2024-26360
CVE-2024-3518
·
Published
2024-05-21
·
Updated
2024-05-22
Description by
CVSS 3.1
8.8
HighMetricsAV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H
Name of the Vulnerable Software and Affected Versions
Media Library Assistant plugin for WordPress versions up to, and including, 3.15
Description
The issue is related to SQL Injection via the plugin's shortcode(s) due to insufficient escaping on the user supplied parameter and lack of sufficient preparation on the existing SQL query. This allows authenticated attackers, with contributor access or higher, to append additional SQL queries into already existing queries, which can be used to extract sensitive information from the database.
Recommendations
For versions up to, and including, 3.15, update to a version higher than 3.15 to resolve the issue.
As a temporary workaround, consider restricting access to the plugin's shortcode(s) to minimize the risk of exploitation.
Found an issue in the description? Have something to add? Feel free to write us 👾