PT-2024-28003

CVE-2024-38439

·

Published

2024-06-16

·

Updated

2025-03-12

Description by

CVSS 3.1
9.8
Critical
MetricsAV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
Name of the Vulnerable Software and Affected Versions Netatalk versions prior to 3.2.1 Netatalk version 3.2.0
Description The issue is caused by an off-by-one error and resultant heap-based buffer overflow in the FPLoginExt function in the login module of etc/uams/uams pam.c. This occurs when setting ibuf[PASSWDLEN] to '0'.
Recommendations For Netatalk version 3.2.0, update to version 3.2.1 or later to resolve the issue. For versions prior to 3.2.1, update to version 3.2.1 or later to resolve the issue. As a temporary workaround, consider restricting access to the FPLoginExt function in the login module until a patch is available.
Exploitability
Exploit
Fix
Impacts
Researchers
Vendors
Affected products
Weakness enumeration
Related identifiers
GHSA-8R68-857C-4RQC
ALT-PU-2024-10064
ALT-PU-2024-10857
ALT-PU-2024-17688
DLA-3968-1
MGASA-2024-0259
SUSE-SU-2024:2301-1
SUSE-SU-2024_2301-1
USN-7347-1
Found an issue in the description? Have something to add? Feel free to write us 👾