PT-2024-28743
CVE-2024-39936
·
Published
2024-06-25
·
Updated
2026-07-06
Description by
CVSS 3.1
8.6
HighMetricsAC:L/AV:N/A:N/C:H/I:N/PR:N/S:C/UI:N
Name of the Vulnerable Software and Affected Versions
Qt versions prior to 5.15.18
Qt versions 6.x prior to 6.2.13
Qt versions 6.3.x through 6.5.x prior to 6.5.7
Qt versions 6.6.x through 6.7.x prior to 6.7.3
Description
An issue was discovered in HTTP2 in Qt where code to make security-relevant decisions about an established connection may execute too early, because the encrypted() signal has not yet been emitted and processed.
Recommendations
For Qt versions prior to 5.15.18, update to version 5.15.18 or later.
For Qt versions 6.x prior to 6.2.13, update to version 6.2.13 or later.
For Qt versions 6.3.x through 6.5.x prior to 6.5.7, update to version 6.5.7 or later.
For Qt versions 6.6.x through 6.7.x prior to 6.7.3, update to version 6.7.3 or later.
Found an issue in the description? Have something to add? Feel free to write us 👾