PT-2024-28905

CVE-2024-40540

·

Published

2024-07-12

·

Updated

2024-08-01

Description by

CVSS 3.1
9.8
Critical
MetricsAV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
Name of the Vulnerable Software and Affected Versions my-springsecurity-plus versions prior to v2024.07.03
Description The issue is related to a SQL injection vulnerability. It can be exploited via the dataScope parameter at the "/api/dept" API endpoint.
Recommendations For versions prior to v2024.07.03, update to version v2024.07.03 or later to resolve the issue. As a temporary workaround, consider restricting access to the "/api/dept" API endpoint or avoiding the use of the dataScope parameter until the update is applied.
Exploitability
Exploit
Fix
Impacts
Researchers
Vendors
Affected products
Related identifiers
Found an issue in the description? Have something to add? Feel free to write us 👾