PT-2024-29456
CVE-2024-4160
·
Published
2024-05-31
·
Updated
2025-03-11
Description by
CVSS 3.1
6.4
MediumMetricsAV:N/AC:L/PR:L/UI:N/S:C/C:L/I:L/A:N
Name of the Vulnerable Software and Affected Versions
Download Manager plugin for WordPress versions up to, and including, 3.2.90
Description
The issue arises from insufficient input sanitization and output escaping on user-supplied attributes in the
wpdm-all-packages shortcode. This allows authenticated attackers with contributor-level access and above to inject arbitrary web scripts in pages. These scripts will execute whenever a user accesses an injected page.Recommendations
For versions up to, and including, 3.2.90, update to a version later than 3.2.90 to resolve the issue.
As a temporary workaround, consider restricting access to the
wpdm-all-packages shortcode to minimize the risk of exploitation. Found an issue in the description? Have something to add? Feel free to write us 👾