PT-2024-29566
CVE-2024-4180
·
Published
2024-06-03
·
Updated
2025-10-31
Description by
CVSS 3.1
9.1
CriticalMetricsAV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:N
Name of the Vulnerable Software and Affected Versions
The Events Calendar WordPress plugin versions prior to 6.4.0.1
Description
The issue arises from the improper sanitization of user-submitted content when rendering certain views via AJAX. This can lead to potential security risks.
Recommendations
For versions prior to 6.4.0.1, update to version 6.4.0.1 or later to resolve the issue. As a temporary workaround, consider restricting access to AJAX-rendered views until the update is applied.
Exploitability
Exploit
Fix
Impacts
Researchers
Vendors
Affected products
Found an issue in the description? Have something to add? Feel free to write us 👾