PT-2024-29819
CVE-2024-42267
·
Published
2024-08-01
·
Updated
2026-08-23
Description by
CVSS 3.1
8.2
HighMetricsAV:N/AC:L/PR:N/UI:N/S:U/C:N/I:L/A:H
Name of the Vulnerable Software and Affected Versions
Linux kernel (affected versions not specified)
Linux kernel versions prior to 6.6.50
Description
The issue is related to the riscv/mm component of the Linux kernel and involves incorrect handling of input, which can lead to a denial of service. The vulnerability is resolved by adding handling for VM FAULT SIGSEGV in the mm fault error() function, ensuring that the process is correctly killed and the kernel does not BUG().
Recommendations
For Linux kernel versions prior to 6.6.50, update to version 6.6.50 or later to resolve the issue.
As a temporary workaround, consider restricting access to the vulnerable riscv/mm component until a patch is available.
Avoid using the
mm fault error() function in sensitive operations until the issue is resolved.
At the moment, there is no information about other newer versions that contain a fix for this vulnerability. Found an issue in the description? Have something to add? Feel free to write us 👾