PT-2024-3038

CVE-2024-32460

·

Published

2024-04-18

·

Updated

2026-03-10

Description by

CVSS 3.1
9.8
Critical
MetricsAV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
Name of the Vulnerable Software and Affected Versions FreeRDP versions prior to 2.11.6 FreeRDP versions prior to 3.5.0
Description The issue is related to an out-of-bounds read in the interleaved decompress() function of the FreeRDP RDP client. This can allow a remote attacker to disclose protected information. The vulnerability affects FreeRDP based clients using the /bpp:32 legacy GDI drawing path.
Recommendations For versions prior to 2.11.6, update to version 2.11.6 to resolve the issue. For versions prior to 3.5.0, update to version 3.5.0 to resolve the issue. As a temporary workaround, consider using modern drawing paths, such as the /rfx or /gfx options, which requires server-side support.
Exploitability
Exploit
Fix
Impacts
Researchers
Vendors
Affected products
Weakness enumeration
Related identifiers
GHSA-4RR8-GR65-VQRR
ALT-PU-2024-6812
ALT-PU-2024-6814
ALT-PU-2024-6847
ALT-PU-2024-6851
ALT-PU-2024-6898
DLA-4053-1
INFSA-2024_9092
MGASA-2024-0157
OESA-2024-1515
OPENSUSE-SU-2024:13900-1
OPENSUSE-SU-2024:14022-1
OPENSUSE-SU-2024_1610-1
OPENSUSE-SU-2026:20339-1
RHSA-2024:9092
RHSA-2024_9092
RLSA-2024:9092
SUSE-SU-2024:1609-1
SUSE-SU-2024:1610-1
USN-6749-1
USN-7341-1
Found an issue in the description? Have something to add? Feel free to write us 👾