PT-2024-30903
CVE-2024-44036
·
Published
2024-10-06
·
Updated
2024-10-07
Description by
CVSS 3.1
5.9
MediumMetricsAV:N/AC:L/PR:H/UI:R/S:C/C:L/I:L/A:L
Name of the Vulnerable Software and Affected Versions
Kodex Posts likes versions through 2.5.0
Description
The issue is related to Improper Neutralization of Input During Web Page Generation, also known as Cross-site Scripting (XSS). It allows for Stored XSS, which means an attacker can inject malicious scripts into a website, and these scripts will be stored on the server, potentially affecting other users.
Recommendations
For versions through 2.5.0, update to version 2.5.1 or later to resolve the issue.
As a temporary workaround, consider restricting user input to prevent malicious scripts from being injected into the website.
Avoid using the vulnerable component until a patch is available.
At the moment, there is no other information about additional mitigation measures.
Found an issue in the description? Have something to add? Feel free to write us 👾