PT-2024-31725
CVE-2024-45679
·
Published
2024-09-17
·
Updated
2025-08-13
Description by
CVSS 3.1
8.4
HighMetricsAV:L/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
Name of the Vulnerable Software and Affected Versions:
Assimp versions prior to 5.4.3
Description:
A heap-based buffer overflow issue allows a local attacker to execute arbitrary code by importing a specially crafted file into the product. This can be achieved through the import functionality of the product.
Recommendations:
For versions prior to 5.4.3, update to version 5.4.3 or later to resolve the issue. As a temporary workaround, consider restricting the import of files from untrusted sources until the update is applied.
Exploitability
Exploit
Fix
Impacts
Researchers
Vendors
Affected products
Found an issue in the description? Have something to add? Feel free to write us 👾