PT-2024-31776
CVE-2024-45795
·
Published
2024-08-01
·
Updated
2025-11-07
Description by
CVSS 2.0
7.8
HighMetricsAV:N/AC:L/Au:N/C:N/I:N/A:C
Name of the Vulnerable Software and Affected Versions:
Suricata versions prior to 7.0.7
Description:
The issue affects Suricata, a network Intrusion Detection System, Intrusion Prevention System, and Network Security Monitoring engine. It occurs when rules using datasets with the non-functional "unset" option are used, potentially triggering an assertion during traffic parsing and leading to denial of service.
Recommendations:
For versions prior to 7.0.7, update to version 7.0.7 to resolve the issue.
As a temporary workaround, use only trusted and well-tested rulesets.
Exploitability
Exploit
Fix
Impacts
Researchers
Vendors
Affected products
Found an issue in the description? Have something to add? Feel free to write us 👾