PT-2024-31790

CVE-2024-4581

·

Published

2024-06-04

·

Updated

2024-06-04

Description by

CVSS 3.1
6.4
Medium
MetricsAV:N/AC:L/PR:L/UI:N/S:C/C:L/I:L/A:N
Name of the Vulnerable Software and Affected Versions: Slider Revolution plugin for WordPress versions up to, and including, 6.7.11
Description: The issue is related to Stored Cross-Site Scripting via the plugin's Add Layer widget due to insufficient input sanitization and output escaping on the user supplied class, id, and title attributes. This allows authenticated attackers, with author-level access and above, to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page. Successful exploitation requires an Administrator to give Slider Creation privileges to Author-level users.
Recommendations: For versions up to, and including, 6.7.11, update to a version later than 6.7.11 to resolve the issue. As a temporary workaround, consider restricting the use of the Add Layer widget or disabling it until a patch is available. Additionally, restrict Slider Creation privileges to only trusted users to minimize the risk of exploitation.
Exploitability
Fix
Impacts
Researchers
Vendors
Affected products
Related identifiers
Found an issue in the description? Have something to add? Feel free to write us 👾