PT-2024-31972
CVE-2024-4637
·
Published
2024-06-04
·
Updated
2024-06-04
Description by
CVSS 3.1
6.4
MediumMetricsAV:N/AC:L/PR:L/UI:N/S:C/C:L/I:L/A:N
Name of the Vulnerable Software and Affected Versions
Slider Revolution plugin for WordPress versions up to, and including, 6.7.10
Description
The issue is related to Stored Cross-Site Scripting due to insufficient input sanitization and output escaping on the user supplied Elementor
wrapperid and zindex display attributes. This allows authenticated attackers, with contributor-level access and above, to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page.Recommendations
For versions up to, and including, 6.7.10, update to a version later than 6.7.10 to resolve the issue.
As a temporary workaround, consider restricting access to the Elementor
wrapperid and zindex display attributes to minimize the risk of exploitation. Found an issue in the description? Have something to add? Feel free to write us 👾