PT-2024-32778

CVE-2024-47731

·

Published

2024-08-22

·

Updated

2025-09-29

Description by

CVSS 3.1
5.5
Medium
MetricsAV:L/AC:L/PR:L/UI:N/S:U/C:N/I:N/A:H
Name of the Vulnerable Software and Affected Versions Linux kernel versions prior to 6.6.58
Description A vulnerability in the Linux kernel has been identified, where the alibaba uncore pmu driver fails to clear all interrupt status in the interrupt processing function. This can lead to an interrupt storm after a PMU counter overflow interrupt occurs, causing the system to hang. The issue is resolved by clearing the correct interrupt status in the interrupt handling function.
Recommendations For versions prior to 6.6.58, update to version 6.6.58 or later to resolve the issue. As a temporary workaround, consider modifying the interrupt handling function to clear the correct interrupt status until a patch is available. Restrict access to the ali drw pmu driver to minimize the risk of exploitation.
Exploitability
Exploit
Fix
Impacts
Vendors
Affected products
Related identifiers
ALSA-2025_16880
ALT-PU-2024-14046
ALT-PU-2024-14268
AZL-51018
DLA-4008-1
MGASA-2024-0344
MGASA-2024-0345
OESA-2024-2296
OPENSUSE-SU-2024:14500-1
OPENSUSE-SU-2024_3984-1
OPENSUSE-SU-2024_3986-1
OPENSUSE-SU-2025:14705-1
SUSE-SU-2024:3984-1
SUSE-SU-2024:3986-1
SUSE-SU-2024:4318-1
SUSE-SU-2024:4387-1
SUSE-SU-2025:20163-1
SUSE-SU-2025:20164-1
SUSE-SU-2025:20246-1
SUSE-SU-2025:20247-1
USN-7276-1
USN-7277-1
USN-7301-1
USN-7303-1
USN-7303-2
USN-7303-3
USN-7304-1
USN-7310-1
USN-7311-1
USN-7384-1
USN-7384-2
USN-7385-1
USN-7386-1
USN-7403-1
Found an issue in the description? Have something to add? Feel free to write us 👾