PT-2024-33289

CVE-2024-48948

·

Published

2024-10-13

·

Updated

2026-08-18

Description by

CVSS 3.1
4.8
Medium
MetricsAV:N/AC:H/PR:N/UI:N/S:U/C:N/I:L/A:L
Name of the Vulnerable Software and Affected Versions Elliptic versions prior to 6.6.0
Description The Elliptic package for Node.js, in its ECDSA implementation, does not correctly verify valid signatures if the hash contains at least four leading 0 bytes and when the order of the elliptic curve's base point is smaller than the hash, because of an truncateToN anomaly. This leads to valid signatures being rejected. Legitimate transactions or communications may be incorrectly flagged as invalid.
Recommendations For versions prior to 6.6.0, update to version 6.6.0 or later to resolve the issue. As a temporary workaround, consider implementing additional validation checks for signatures to minimize the risk of incorrectly flagging legitimate transactions or communications as invalid. Restrict the use of the ECDSA implementation in the Elliptic package until the update is applied.
Exploitability
Exploit
Fix
Impacts
Researchers
Vendors
Affected products
Related identifiers
GHSA-FC9H-WHQ2-V747
OPENSUSE-SU-2024:14433-1
OPENSUSE-SU-2024_3771-1
OPENSUSE-SU-2025:14663-1
OPENSUSE-SU-2026:11220-1
SUSE-SU-2024:3771-1
SUSE-SU-2025:3744-1
Found an issue in the description? Have something to add? Feel free to write us 👾