PT-2024-33865
CVE-2024-50024
·
Published
2024-10-21
·
Updated
2026-07-28
Description by
CVSS 3.1
7.3
HighMetricsAV:L/AC:L/PR:L/UI:R/S:U/C:H/I:H/A:H
Name of the Vulnerable Software and Affected Versions:
Linux kernel versions prior to 6.6.58
Description:
The issue is related to an unsafe loop on the list in the Linux kernel, which can cause the kernel to crash when deleting a genetlink family if there are still listeners for that family. This can lead to a kernel access of bad area, resulting in a crash. The problem is caused by an element removal from the list inside the loop.
Recommendations:
For versions prior to 6.6.58, update to version 6.6.58 or later to resolve the issue. As a temporary workaround, consider restricting the deletion of genetlink families when there are still listeners for that family to minimize the risk of kernel crash.
Exploitability
Exploit
Fix
Impacts
Researchers
Vendors
Affected products
Found an issue in the description? Have something to add? Feel free to write us 👾