PT-2024-33973
CVE-2024-50141
·
Published
2024-11-07
·
Updated
2025-10-03
Description by
CVSS 3.1
7.8
HighMetricsAV:L/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H
Name of the Vulnerable Software and Affected Versions:
Linux kernel versions prior to 6.6.61
Description:
The issue arises because the PRMT is finding a block of type EFI CONVENTIONAL MEMORY, which is not appropriate for runtime services as described in Section 2.2.2 (Runtime Services) of the UEFI Specification. This causes an exception when the PRM handler is called, resulting in a failure during error handling. The problem is that only memory that has been remapped for runtime by the firmware can be used by the PRM handler, and so the region needs to have the EFI MEMORY RUNTIME attribute. By using the correct memory types for runtime services, the PRM handler and the context are properly mapped in the virtual address space during runtime, preventing the paging request error.
Recommendations:
Update to Linux kernel version 6.6.61 or later to resolve the issue. As a temporary workaround, consider restricting access to the PRM handler until a patch is available. Ensure that the correct memory types are used for runtime services to prevent the paging request error.
Found an issue in the description? Have something to add? Feel free to write us 👾