PT-2024-34044
CVE-2024-50209
·
Published
2024-10-08
·
Updated
2025-10-03
Description by
CVSS 3.1
7.8
HighMetricsAV:L/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H
Name of the Vulnerable Software and Affected Versions:
Linux kernel versions prior to 6.6.61
Description:
A vulnerability in the Linux kernel has been resolved, specifically in the RDMA/bnxt re module. The issue involved the
alloc pbl() function, which can return an error when memory allocation fails, but the driver was not checking the status in one of the instances.Recommendations:
For versions prior to 6.6.61, update to version 6.6.61 or later to resolve the issue. As a temporary workaround, consider restricting access to the RDMA/bnxt re module until the update is applied.
Found an issue in the description? Have something to add? Feel free to write us 👾