PT-2024-34080
CVE-2024-50248
·
Published
2024-08-23
·
Updated
2026-01-13
Description by
CVSS 3.1
7.8
HighMetricsAV:L/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H
Name of the Vulnerable Software and Affected Versions:
Linux kernel versions prior to 6.6.61
Description:
The issue concerns a lack of bounds checking in the
mi enum attr() function within the ntfs3 module of the Linux kernel. This has been resolved by adding bounds checking to ensure that attributes do not access memory beyond valid regions.Recommendations:
For versions prior to 6.6.61, update to version 6.6.61 or later to resolve the issue. As a temporary workaround, consider restricting access to the
ntfs3 module until a patch is available. Found an issue in the description? Have something to add? Feel free to write us 👾