PT-2024-35071
CVE-2024-51938
·
Published
2024-11-19
·
Updated
2025-03-31
Description by
CVSS 3.1
6.5
MediumMetricsAV:N/AC:L/PR:L/UI:R/S:C/C:L/I:L/A:L
Name of the Vulnerable Software and Affected Versions
NicheAddons Charity Addon for Elementor versions 1.3.2 and earlier
Description
The issue is related to Improper Neutralization of Input During Web Page Generation, also known as Cross-site Scripting, allowing DOM-Based XSS. This means that an attacker could potentially inject malicious scripts into the webpage, affecting the Document Object Model (DOM), which is the structure of the webpage.
Recommendations
For NicheAddons Charity Addon for Elementor versions 1.3.2 and earlier, update to a version later than 1.3.2 to resolve the issue.
At the moment, there is no information about additional mitigation measures for this specific vulnerability.
Found an issue in the description? Have something to add? Feel free to write us 👾