PT-2024-36065

CVE-2024-54137

·

Published

2024-12-06

·

Updated

2025-03-31

Description by

CVSS 3.1
7.5
High
MetricsAV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N
Name of the Vulnerable Software and Affected Versions: liboqs versions prior to 0.12.0
Description: A correctness error has been identified in the reference implementation of the HQC key encapsulation mechanism in liboqs, a C-language cryptographic library. The error is due to an indexing issue, causing part of the secret key to be incorrectly treated as non-secret data. This results in an incorrect shared secret value being returned when the decapsulation function is called with a malformed ciphertext.
Recommendations: For versions prior to 0.12.0, update to version 0.12.0 to resolve the issue.
Exploitability
Exploit
Fix
Impacts
Researchers
Vendors
Affected products
Related identifiers
GHSA-GPF4-VRRW-R8V7
ALT-PU-2024-16894
ALT-PU-2024-17674
OPENSUSE-SU-2024:14580-1
OPENSUSE-SU-2025_0005-1
SUSE-SU-2025:0005-1
Found an issue in the description? Have something to add? Feel free to write us 👾