PT-2024-36276
CVE-2024-5439
·
Published
2024-06-05
·
Updated
2024-06-11
Description by
CVSS 3.1
6.4
MediumMetricsAV:N/AC:L/PR:L/UI:N/S:C/C:L/I:L/A:N
Name of the Vulnerable Software and Affected Versions:
Blocksy theme for WordPress versions up to, and including, 2.0.50
Description:
The issue is related to Reflected Cross-Site Scripting via the
custom url parameter due to insufficient input sanitization and output escaping. This allows unauthenticated attackers to inject arbitrary web scripts in pages that execute if they can successfully trick a user into performing an action such as clicking on a link.Recommendations:
For Blocksy theme for WordPress versions up to, and including, 2.0.50, update to a version higher than 2.0.50 to resolve the issue.
As a temporary workaround, consider restricting access to the
custom url parameter to minimize the risk of exploitation. Found an issue in the description? Have something to add? Feel free to write us 👾