PT-2024-36511
CVE-2024-5536
·
Published
2024-06-05
·
Updated
2024-06-11
Description by
CVSS 3.1
6.4
MediumMetricsAV:N/AC:L/PR:L/UI:N/S:C/C:L/I:L/A:N
Name of the Vulnerable Software and Affected Versions
GamiPress – Link plugin for WordPress versions up to, and including, 1.1.4
Description
The issue is related to Stored Cross-Site Scripting via the plugin's
gamipress link shortcode due to insufficient input sanitization and output escaping on user-supplied attributes. This allows authenticated attackers with contributor-level access and above to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page.Recommendations
For versions up to, and including, 1.1.4, update to a version higher than 1.1.4 to resolve the issue.
As a temporary workaround, consider restricting access to the
gamipress link shortcode until a patch is available. Found an issue in the description? Have something to add? Feel free to write us 👾