PT-2024-36699
CVE-2024-56064
·
Published
2024-12-31
·
Updated
2025-01-27
Description by
CVSS 3.1
10
CriticalMetricsAV:N/AC:L/PR:N/UI:N/S:C/C:H/I:H/A:H
Name of the Vulnerable Software and Affected Versions
WP SuperBackup versions 2.3.3 and earlier
Description
The issue affects the WP SuperBackup plugin for WordPress, allowing unrestricted upload of files with dangerous types. This enables attackers to upload a web shell to a web server. The vulnerability is due to missing file type validation in all versions up to and including 2.3.3.
Recommendations
For WP SuperBackup versions 2.3.3 and earlier, update to version 2.3.4 to patch this issue. As a temporary workaround, consider restricting access to the file upload functionality until the update is applied.
Found an issue in the description? Have something to add? Feel free to write us 👾