PT-2024-36902
CVE-2024-56595
·
Published
2024-10-29
·
Updated
2026-02-21
Description by
CVSS 3.1
7.8
HighMetricsAV:L/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H
Name of the Vulnerable Software and Affected Versions
Linux kernel versions prior to 6.6.74
Description
A vulnerability in the Linux kernel has been resolved. The issue is related to an array-index-out-of-bounds condition in the
dbAdjTree function of the jfs module. When the value of lp is 0 at the beginning of the for loop, it becomes negative in the next assignment, requiring the loop to terminate.Recommendations
For Linux kernel versions prior to 6.6.74, update to version 6.6.74 or later to resolve the issue. As a temporary workaround, consider disabling the jfs module until a patch is available. Restrict access to the
dbAdjTree function to minimize the risk of exploitation. Avoid using the lp variable in the affected loop until the issue is resolved. Found an issue in the description? Have something to add? Feel free to write us 👾