PT-2024-36903
CVE-2024-56596
·
Published
2024-10-29
·
Updated
2025-12-04
Description by
CVSS 3.1
8.0
HighMetricsAV:A/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H
Name of the Vulnerable Software and Affected Versions
Linux kernel versions prior to 6.6.74
Description
A vulnerability has been resolved in the Linux kernel, specifically in the jfs readdir function, where an array-index-out-of-bounds error could occur. The stbl might contain some invalid values, and a check has been added to return an error code in such cases.
Recommendations
For versions prior to 6.6.74, update to version 6.6.74 or later to resolve the issue.
As a temporary workaround, consider disabling the
jfs readdir function until a patch is available. Found an issue in the description? Have something to add? Feel free to write us 👾