PT-2024-36905
CVE-2024-56598
·
Published
2024-10-29
·
Updated
2026-02-21
Description by
CVSS 3.1
7.8
HighMetricsAV:L/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H
Name of the Vulnerable Software and Affected Versions
Linux kernel versions prior to 6.6.74
Description
The issue is related to an array-index-out-of-bounds fix in the
dtReadFirst function of the jfs filesystem. The value of stbl can sometimes be out of bounds due to a bad filesystem, and a check has been added to return an error code in such cases.Recommendations
For Linux kernel versions prior to 6.6.74, update to version 6.6.74 or later to resolve the issue. As a temporary workaround, consider adding additional checks for filesystem integrity to minimize the risk of exploitation.
Found an issue in the description? Have something to add? Feel free to write us 👾