PT-2024-37200

CVE-2024-5861

·

Published

2024-07-24

·

Updated

2024-07-29

Description by

CVSS 3.1
6.5
Medium
MetricsAV:N/AC:L/PR:N/UI:N/S:U/C:N/I:L/A:L
Name of the Vulnerable Software and Affected Versions: WP EasyPay – Square for WordPress plugin versions up to, and including, 4.2.3
Description: The issue allows unauthorized modification of data due to a missing capability check on the wpep square disconnect() function. This makes it possible for unauthenticated attackers to disconnect Square.
Recommendations: For WP EasyPay – Square for WordPress plugin versions up to, and including, 4.2.3, update to a version higher than 4.2.3 to resolve the issue. As a temporary workaround, consider disabling the wpep square disconnect() function until a patch is available.
Exploitability
Fix
Impacts
Researchers
Vendors
Affected products
Weakness enumeration
Related identifiers
Found an issue in the description? Have something to add? Feel free to write us 👾