PT-2024-37259

CVE-2024-5945

·

Published

2024-06-21

·

Updated

2024-06-24

Description by

CVSS 3.1
6.4
Medium
MetricsAV:N/AC:L/PR:L/UI:N/S:C/C:L/I:L/A:N
Name of the Vulnerable Software and Affected Versions: WP SVG Images plugin for WordPress versions up to, and including, 4.2
Description: The issue is related to Stored Cross-Site Scripting via the type parameter due to insufficient input sanitization. This allows authenticated attackers with Author-level access and above, who have permissions to upload sanitized files, to bypass SVG sanitization and inject arbitrary web scripts in pages. These scripts will execute whenever a user accesses an injected page.
Recommendations: For WP SVG Images plugin for WordPress versions up to, and including, 4.2, update to a version higher than 4.2 to resolve the issue. As a temporary workaround, consider restricting access to the type parameter to minimize the risk of exploitation.
Exploitability
Fix
Impacts
Researchers
Vendors
Affected products
Related identifiers
Found an issue in the description? Have something to add? Feel free to write us 👾