PT-2024-37588

CVE-2024-6391

·

Published

2024-07-09

·

Updated

2024-07-09

Description by

CVSS 3.1
6.4
Medium
MetricsAV:N/AC:L/PR:L/UI:N/S:C/C:L/I:L/A:N
Name of the Vulnerable Software and Affected Versions oik plugin for WordPress versions up to, and including, 4.10.3
Description The issue is related to Stored Cross-Site Scripting via the plugin's bw button shortcode due to insufficient input sanitization and output escaping on user-supplied attributes. This allows authenticated attackers with contributor-level access and above to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page.
Recommendations For versions up to, and including, 4.10.3, update to a version later than 4.10.3 to resolve the issue. As a temporary workaround, consider restricting access to the bw button shortcode until a patch is available.
Exploitability
Fix
Impacts
Researchers
Vendors
Affected products
Related identifiers
Found an issue in the description? Have something to add? Feel free to write us 👾