PT-2024-38801
CVE-2024-8097
·
Published
2024-09-11
·
Updated
2024-09-12
Description by
CVSS 4.0
6.7
MediumMetricsAV:L/AC:L/AT:N/PR:H/UI:A/VC:H/VI:N/VA:N/SC:H/SI:N/SA:N/E:X/CR:X/IR:X/AR:X/MAV:X/MAC:X/MAT:X/MPR:X/MUI:X/MVC:X/MVI:X/MVA:X/MSC:X/MSI:X/MSA:X/S:X/AU:X/R:X/V:X/RE:X/U:X
Name of the Vulnerable Software and Affected Versions:
Payara Server versions 4.1.2.191.0 through 4.1.2.191.50
Payara Server versions 5.20.0 through 5.67.0
Payara Server versions 5.2020.2 through 5.2022.5
Payara Server versions 6.0.0 through 6.18.0
Payara Server versions 6.2022.1 through 6.2024.9
Description:
The issue affects the Payara Platform Payara Server, specifically the logging modules, allowing sensitive credentials to be posted in plain text on the server log. This exposes sensitive information to unauthorized actors.
Recommendations:
For Payara Server versions 4.1.2.191.0 through 4.1.2.191.50, update to version 4.1.2.191.50 or later.
For Payara Server versions 5.20.0 through 5.67.0, update to version 5.67.0 or later.
For Payara Server versions 5.2020.2 through 5.2022.5, update to version 5.2022.5 or later.
For Payara Server versions 6.0.0 through 6.18.0, update to version 6.18.0 or later.
For Payara Server versions 6.2022.1 through 6.2024.9, update to version 6.2024.9 or later.
Found an issue in the description? Have something to add? Feel free to write us 👾