PT-2024-38874
CVE-2024-8215
·
Published
2024-10-08
·
Updated
2024-10-16
Description by
CVSS 4.0
8.7
HighMetricsAV:N/AC:H/AT:P/PR:H/UI:A/VC:H/VI:H/VA:H/SC:H/SI:H/SA:H
Name of the Vulnerable Software and Affected Versions:
Payara Server versions 4.1.2.191.1 through 4.1.2.191.50
Payara Server versions 5.20.0 through 5.67.0
Payara Server versions 6.0.0 through 6.18.0
Payara Server versions 6.2022.1 through 6.2024.9
Description:
The issue affects the Payara Server, specifically the Admin Console modules, due to an Improper Neutralization of Input During Web Page Generation, also known as Cross-site Scripting (XSS). This allows for Remote Code Inclusion.
Recommendations:
For Payara Server versions 4.1.2.191.1 through 4.1.2.191.50, update to version 4.1.2.191.51 or later.
For Payara Server versions 5.20.0 through 5.67.0, update to version 5.68.0 or later.
For Payara Server versions 6.0.0 through 6.18.0, update to version 6.19.0 or later.
For Payara Server versions 6.2022.1 through 6.2024.9, update to version 6.2024.10 or later.
Found an issue in the description? Have something to add? Feel free to write us 👾