PT-2024-39488

CVE-2024-9205

·

Published

2024-10-09

·

Updated

2024-10-15

Description by

CVSS 3.1
6.1
Medium
MetricsAV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N
Name of the Vulnerable Software and Affected Versions Maximum Products per User for WooCommerce plugin for WordPress versions up to, and including, 4.2.8
Description The issue arises from the use of add query arg without proper escaping on the URL, leading to Reflected Cross-Site Scripting. This allows unauthenticated attackers to inject arbitrary web scripts into pages, which execute when a user performs a specific action, such as clicking on a link. The attackers can trick users into taking such actions.
Recommendations For versions up to, and including, 4.2.8, update to a version higher than 4.2.8 to resolve the issue. As a temporary workaround, consider restricting access to the add query arg function until a patch is available.
Exploitability
Fix
Impacts
Researchers
Vendors
Affected products
Related identifiers
Found an issue in the description? Have something to add? Feel free to write us 👾