PT-2024-40138

Published

2024-05-21

·

Updated

2024-05-21

Description by

CVSS 3.1
6.1
Medium
MetricsAV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N
Name of the Vulnerable Software and Affected Versions: sensiolabs/connect versions prior to 4.2.3
Description: The issue is related to a Cross-Site Request Forgery (CSRF) vulnerability. It occurs due to the absence of the state parameter in OAuth requests, which exposes applications to CSRF attacks during the OAuth authentication flow.
Recommendations: For versions prior to 4.2.3, update to version 4.2.3 or later to resolve the issue. As a temporary workaround, consider implementing proper state parameter handling in OAuth requests to prevent CSRF attacks.
Exploitability
Fix
Impacts
Vendors
Affected products
Related identifiers
GHSA-6WQP-7G94-F69J
Found an issue in the description? Have something to add? Feel free to write us 👾