PT-2024-4425
CVE-2024-5629
·
Published
2024-06-05
·
Updated
2026-10-13
Description by
CVSS 3.1
8.1
HighMetricsAV:N/AC:L/PR:N/UI:R/S:U/C:H/I:N/A:H
Name of the Vulnerable Software and Affected Versions
PyMongo versions 4.6.2 and earlier
Description
The issue is related to an out-of-bounds read in the 'bson' module, allowing deserialization of malformed BSON provided by a server. This can lead to an exception that may contain arbitrary application memory, potentially revealing confidential information or causing a denial of service.
Recommendations
For PyMongo versions 4.6.2 and earlier, update to version 4.6.3 or later to resolve the issue.
As a temporary workaround, consider restricting the use of the 'bson' module until a patch is available.
Exploitability
Exploit
Fix
Impacts
Researchers
Vendors
Affected products
Found an issue in the description? Have something to add? Feel free to write us 👾