PT-2024-4558

CVE-2024-29510

·

Published

2024-05-09

·

Updated

2026-11-01

Description by

CVSS 3.1
6.3
Medium
MetricsAV:L/AC:L/PR:N/UI:R/S:C/C:H/I:N/A:N
Name of the Vulnerable Software and Affected Versions Ghostscript versions prior to 10.03.1
Description A format string injection flaw exists in the uniprint device of Ghostscript, a PostScript and PDF interpreter. The issue occurs because the device allows users to pass string fragments as options—specifically upWriteComponentCommands and upYMoveCommand—which are then processed as format strings by the gp fprintf() and gs snprintf() functions without proper restriction. This can lead to memory corruption, data leakage from the stack, and a bypass of the SAFER sandbox, which is a security mode designed to prevent PostScript code from executing dangerous commands or accessing arbitrary files. Successful exploitation may allow an unauthenticated remote attacker to execute arbitrary code in the context of the Ghostscript process, potentially leading to full system compromise if the software is running with elevated privileges.
Recommendations Upgrade to Ghostscript version 10.03.1 or later. As a temporary mitigation, disable Ghostscript delegates and restrict the processing of PDF and PS files.
Exploitability
Exploit
Fix
Impacts
Researchers
Vendors
Affected products
Related identifiers
ALSA-2024:6197
ALT-PU-2024-13477
ALT-PU-2024-14136
ALT-PU-2024-14302
DSA-5692-1
INFSA-2024_6197
MGASA-2024-0192
OESA-2024-2159
OESA-2024-2162
OESA-2024-2163
OPENSUSE-SU-2024:14090-1
OPENSUSE-SU-2024_2292-1
RHSA-2024:6197
RHSA-2024_6197
RHSA-2024:6466
SUSE-SU-2024:2276-1
SUSE-SU-2024_2276-1
SUSE-SU-2024:2292-1
SUSE-SU-2024_2292-1
USN-6835-1
Found an issue in the description? Have something to add? Feel free to write us 👾