PT-2024-5030
CVE-2024-29509
·
Published
2024-01-24
·
Updated
2026-06-24
Description by
CVSS 3.1
8.8
HighMetricsAV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H
Name of the Vulnerable Software and Affected Versions:
Artifex Ghostscript versions prior to 10.03.0
Description:
The issue is related to a heap-based overflow when the
PDFPassword parameter has a 000 byte in the middle, which can be exploited by a remote attacker to cause a denial of service.Recommendations:
For versions prior to 10.03.0, update to version 10.03.0 or later to resolve the issue. As a temporary workaround, consider restricting the use of the
PDFPassword parameter to minimize the risk of exploitation.Exploitability
Exploit
Fix
Impacts
Researchers
Vendors
Affected products
Found an issue in the description? Have something to add? Feel free to write us 👾