PT-2024-5856
CVE-2024-3772
·
Published
2024-04-14
·
Updated
2026-08-05
Description by
CVSS 3.1
7.5
HighMetricsAV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
Name of the Vulnerable Software and Affected Versions
Pydantic versions prior to 2.4.0
Pydantic versions prior to 1.10.13
Description
The issue is related to the use of regular expressions in the Pydantic library, which can lead to a denial of service when exploited by a remote attacker. This can be achieved via a crafted email string, allowing the attacker to cause a denial of service.
Recommendations
For versions prior to 2.4.0, update to version 2.4.0 or later to resolve the issue.
For versions prior to 1.10.13, update to version 1.10.13 or later to resolve the issue.
Exploitability
Exploit
Fix
Impacts
Researchers
Vendors
Affected products
Found an issue in the description? Have something to add? Feel free to write us 👾